A weekly comic about programming, browsers and geek stuff.

Internet Explorer

The only thing Internet Explorer is good for is downloading Firefox.
https://comic.browserling.com/46
Cartoon tags:
ie, internet explorer, iexplore, explorer, microsoft, firefox, mozilla, mozilla firefox, download, install, wdywtgt, where do you want to go today, install firefox, download firefox, file, edit, view, favorites, tools, help, fox, earth
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING46 to get a discount on developer and team plans!
(c) 2017 Browserling Inc. All rights reserved.