A weekly comic about programming, browsers and geek stuff.

1023MB

There's a band called 1023MB. They haven't had a gig yet.
https://comic.browserling.com/29
Cartoon tags:
1023MB, megabyte, 1GB, gigabyte, gig, band, music, 1023 MB, 1023 megabytes, 1 GB, 1 gigabyte, computer
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING29 to get a discount on developer and team plans!
(c) 2017 Browserling Inc. All rights reserved.