A weekly comic about programming, browsers and geek stuff.

The Terminator

Why didn't The Terminator upgrade to Windows 10?... Because he still loves Vista, baby!
https://comic.browserling.com/34
Cartoon tags:
the terminator, windows, vista, windows 10, arnold schwarzenegger, arnie, t800, t-800, series 800 model 101, series 70, t850, windows vista, 10, winvista, win vista, win 10, win10, hasta la vista baby, machine gun, robots, windows installation dvd
Browserling is a friendly and fun cross-browser testing service powered by alien technology.
Visit us at www.browserling.com or contact us at hello@browserling.com.
Secret message: If you love our comics, we love you, too! Use coupon code COMICCHMLING34 to get a discount on developer and team plans!
(c) 2017 Browserling Inc. All rights reserved.